Maglev haptic Application Programming Interface Release 1.5

Issues, bugs, and discussion of the Maglev Haptics API 1.5.

Packages for Ubuntu

I'm trying to get the cube demo to run.  I've installed coin3d through the package manager on Ubuntu, but I get this error when I try to compile:

/usr/bin/ld: cannot find -lInventorXt
collect2: ld returned 1 exit status
make: *** [../../../../bin/cube_linux] Error 1
 

What am I missing?

 

 Hi, I tried to reproduce the

 Hi,

I tried to reproduce the exact error, but can't. Here is what it looks like to me: You might not have SoXt installed.

1) When you install Coin3D, that will NOT install a package called SoXt you also need. It is the Coin3D window manager. You have to download it separately from the coin3D website since it is not listed in the Ubuntu Package Manager.

2) Download SoXt source code.

3) Copy it in a folder and run the following commands:

./configure

make

sudo make install

4) After entering the su password, SoxT should be installed and ready to go

5) Try to recompile the demo again.

 

Let's see whether that works, good luck.